ЭЛСИ-сервис. Региональный технический центр компании LG-Ericsson.

Технический форум по настройке и эксплуатации АТС

Текущее время: 25 окт 2020, 23:16

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 17 ]  На страницу Пред.  1, 2
Автор Сообщение
 Заголовок сообщения: Re: Не работает WTIM4
Непрочитанное сообщениеДобавлено: 22 окт 2019, 18:56 
Не в сети
Администратор
Аватар пользователя

Зарегистрирован: 28 дек 2010, 16:13
Сообщений: 7414
Откуда: Тула
Благодарил (а): 1 раз.
Поблагодарили: 546 раз.
VSh писал(а):
Теперь по основному...

update / ARMBoot Env
Код:
Flashing partition at 0x113f2000-0x113f3fff
.
ARMBoot Env Erase Done!!!
.
ARMBoot Env Write Done!!!
Flashing partition at 0x113f0000 - 0x113f1fff
Storing address ***
.
MAC addr Erase Done!!!
.
MAC addr Write Done!!!
making environment backup...
Erasing backup env area [0x113f4000]...
.Erasing backup env area [0x113f6000]...
.
Programming backup env area [0x113f4000]...
..
WTIM-Boot> 


update / ARMBoot
Код:
Received file, size=130804
Flashing partition at 0x11000000-0x1107ffff
..
ARMBoot Erase Done!!!
..
ARMBoot Write Done!!!
WTIM-Boot>


update / Kernel
Код:
Received file, size=2716947
Flashing partition at 0x11080000-0x113effff
..........................................
Kernel Erase Done!!!
..........................................
Kernel Write Done!!!
write kernel image to nand file system...
yaffs: block 32 is bad
WTIM-Boot>

Вот эту концовку как понимать? Сначала Kernel Write Done, а потом block 32 is bad. Оно как-то разрулило битый блок или это ошибка?

update / RFS
Код:
Received file, size=4823808
 update RFS: Erasing 960 blocks...
 update RFS: Write 4823808 bytes...
Write block=67, page=63, bytes=540672
 -> bad block at 880000 (blk=68), skip
Write block=100, page=43, bytes=4823808
WTIM-Boot>

Аналогично, bad block at 880000 (blk=68), skip - оно его пропустило и записало далее "как надо" или нет?

После манипуляций сеть поднялась, но по прежнему CP1 off, CP2 on

При SW1-3 = ON теперь она проходит чуть дальше:
Код:
recover_env : entry...
recover_env : exit...
ARMboot Bz17934_1 lge NORFLASHBOOT  (Dec 21 2010 - 14:33:02)
ARMboot code: 01f00000 -> 01f41f70
NAND CHIP : 0
NAND MID:0xec, Chip ID:0xf1 (Samsung NAND 128MB 3,3V)
Comcerto info:
  CPU:                 M828xx
  EVM:             WTIM
  SDC Version:     0x560e
  SDC Device ID:   0x130
  Bounding option: 0xec89
CFG HZ:            132000000
NAND MSP start:    1
NAND MSP size:     31
NAND CSP start:    32
NAND CSP size:     32
NOR Base addr:     0x11000000
EPROM Base addr:   0x00000000
DRAM Configuration:
Bank #0: 01000000 48 MB


При SW1-3 = OFF:
начало то же, затем ещё пара сотен строк лога и всё останавливается на
Код:
Nios Init.........................

Я же написал, что надо пробовать выполнить процедуру RECOVERY! С самого начала понятно было, что у вас с памятью проблемы! Зачем вы тратите время на эти вот логи?!

_________________
Вот смотрю я на вас и думаю: ещё выпить, или вы мне уже нравитесь? Анекдот
можно отблагодарить специалиста за помощь


Вернуться наверх
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает WTIM4
Непрочитанное сообщениеДобавлено: 22 окт 2019, 19:22 
Не в сети
Участник

Зарегистрирован: 22 окт 2019, 10:26
Сообщений: 10
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.
Dron писал(а):
Я же написал, что надо пробовать выполнить процедуру RECOVERY! С самого начала понятно было, что у вас с памятью проблемы! Зачем вы тратите время на эти вот логи?!

To Recover iPECS-GW completely, it needs 3 Files and TFTP program
Вот я ровно эти 3 файла ему и залил, логи как раз от процесса заливки
И результат заливки Kernel и RFS я не могу интерпретировать точно - оно записалось или нет?

Или инструкция RECOVERY что-то умалчивает "между строк"? Как было - так и выполнил. Только заливал я не TFTP, а Kermit, т.к. сеть была упавшая.

Ну и инструкция не предусматривает 128 GB NAND для WTIM, но у меня именно такой и соотв. файл .jaffs2 имеется, его и прошил


Вернуться наверх
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает WTIM4
Непрочитанное сообщениеДобавлено: 22 окт 2019, 20:56 
Не в сети
Администратор
Аватар пользователя

Зарегистрирован: 28 дек 2010, 16:13
Сообщений: 7414
Откуда: Тула
Благодарил (а): 1 раз.
Поблагодарили: 546 раз.
Ну, ежели сделали все по инструкции и логи отображали процессы при заливке файлов аналогично примеру из инструкции, то добавить мне нечего. У меня был аналогичный модуль. Как бы файлы закачивались, но он так и не запустился. Видимо, в ремонт надо отправлять.

_________________
Вот смотрю я на вас и думаю: ещё выпить, или вы мне уже нравитесь? Анекдот
можно отблагодарить специалиста за помощь


Вернуться наверх
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает WTIM4
Непрочитанное сообщениеДобавлено: 22 окт 2019, 21:56 
Не в сети
Участник

Зарегистрирован: 22 окт 2019, 10:26
Сообщений: 10
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.
Да там и инструкция "плавает" в деталях...
Например, сказано что на NOR расположены boot, DSP+kernel1, Env. А на NAND - DSP+kernel2 (а соотв.файла нет!!!) и RFS. И при update / Kernel оно предлагает 2 варианта:
* Choose Image Destination *
* 0 NOR Flash *
* 1 NAND Flash (Smart Media) *

Для "0 NOR Flash" прошивка есть, а для для "1 NAND Flash (Smart Media)" что шить?

А с живого модуля эти прошивки сдампить можно?


Вернуться наверх
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает WTIM4
Непрочитанное сообщениеДобавлено: 22 окт 2019, 22:16 
Не в сети
Администратор
Аватар пользователя

Зарегистрирован: 28 дек 2010, 16:13
Сообщений: 7414
Откуда: Тула
Благодарил (а): 1 раз.
Поблагодарили: 546 раз.
Я же сказал, что мне нечего добавить. Сам пользуюсь тем, что дал вам. Собственно, все это и пользуют!

_________________
Вот смотрю я на вас и думаю: ещё выпить, или вы мне уже нравитесь? Анекдот
можно отблагодарить специалиста за помощь


Вернуться наверх
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает WTIM4
Непрочитанное сообщениеДобавлено: 22 окт 2019, 23:48 
Не в сети
Участник

Зарегистрирован: 22 окт 2019, 10:26
Сообщений: 10
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.
Я же без претензий, спасибо за то что есть.

Кстати, после каких-то манипуляций Kernel1 прошился без ошибок.

И RFS прошился вот так:
Received file, size=4823808
NAND MID:0xec, Chip ID:0xf1 (Samsung NAND 128MB 3,3V)
Erasing RFS from NAND...
Check bad block: 67 nand_erase: bad block[68] at page [4352]
Check bad block: 1023
Erase block: 1023
Writing RFS to NAND...start[64]
iPECS_RootFS_Image, [4823808]
Write: block=101, pages=43, bytes=4823808
Writing RFS succeeded.

Но в целом результат тот же. В зависимости от того, что случится раньше (или появится время везти в ремонт или буду рядом с другим живым модуле) может ещё посмотрю как это всё выглядит на исправном модуле и сравню.

А непонятно в чём состоит ремонт? Флэш сдох и его меняют?


Вернуться наверх
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает WTIM4
Непрочитанное сообщениеДобавлено: 23 окт 2019, 09:15 
Не в сети
Администратор
Аватар пользователя

Зарегистрирован: 28 дек 2010, 16:13
Сообщений: 7414
Откуда: Тула
Благодарил (а): 1 раз.
Поблагодарили: 546 раз.
VSh писал(а):
А непонятно в чём состоит ремонт? Флэш сдох и его меняют?

Ну да, а какие еще варианты? Думаю, еще и как то прошивают....

_________________
Вот смотрю я на вас и думаю: ещё выпить, или вы мне уже нравитесь? Анекдот
можно отблагодарить специалиста за помощь


Вернуться наверх
 Профиль  
Ответить с цитатой  
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 17 ]  На страницу Пред.  1, 2

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
 cron
Powered by phpBB® Forum Software © phpBB Group
Русская поддержка phpBB


Rambler Top100